Windows 10 sagt „Kein Internet“, aber das Internet funktioniert

Waren Sie schon einmal in der Situation, dass Ihr Computer mit dem Internet verbunden ist, Sie aber keine Seite im Internet öffnen können? Nun, das ist ein seltsames, aber oft lösbares Problem. Wenn Sie über einen WiFi-Router mit dem Internet verbunden sind, aber keine Webseite aufrufen können, überprüfen Sie Ihr WLAN-Symbol in der unteren rechten Seitenleiste. Wahrscheinlich sehen Sie dort ein kleines gelbes Dreieck, und wenn Sie darauf klicken, erscheint die Meldung „Kein Internet, gesichert“.

Dieser Fehler kann aus verschiedenen Gründen auftreten. Der häufigste Grund ist eine Änderung Ihrer Konfigurationseinstellungen, z. B. Ihrer IP-Adresse, die dazu führen kann, dass Ihr Router Probleme bei der Verbindung mit dem Internet hat. Jedes Programm, einschließlich einer Aktualisierung des Betriebssystems, kann dieses Problem verursachen.

Fehlermeldung ‚Kein Internet‘, obwohl das Surfen funktioniert

Hintergrund ist dieser Microsoft Answers-Forenthread vom 30. Januar 2020, in dem ein Nutzer schreibt:

DNS manuell zugewiesen – jetzt denkt win10, es gäbe kein Internet. Beim Surfen funktioniert es aber.

Sobald ich im IP4-Protokoll der Netzwerkkarte manuell DNS-Serveradressen eintrage, glaubt WIN10 nach dem Neustart, dass keine Internetverbindung besteht.

Unten rechts Weltkugel mit Verbotszeichen. Spotify meldet offline usw. Ich kann aber mit allen Browsern sehr schnell im Internet surfen.

Ich stelle die DNS-Serveradresse wieder auf automatisch, starte neu, Internet wird angezeigt und alles funktioniert.

Die manuellen DNS-Server sind viel schneller, daher würde ich sie gerne nutzen.

Meine Frage. Warum behauptet WIN10, dass es kein Internet mit manuellen DNS-Servern gibt oder wie erkennt es manuelle DNS-Adressen?

Der Benutzer war an dieser Stelle etwas perplex und fragte, ob jemand einen Trick/Tipp für ihn hätte.

Einem Registry-Eintrag die Schuld geben

Im Forumsthread berichtete der Benutzer später und vermutete, dass wahrscheinlich ein Registry-Eintrag im Schlüssel:

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
Dienste\NlaSvc\Parameter\Internet

wird dieses Verhalten verursachen. Und am 29. Januar 2020 gab es eine Auflösung, dass der DWORD-Wert EnableActiveProbing = 0 gesetzt wurde. Damit wurde der entsprechende Test von Windows auf manuell eingestellte DNS-Adressen deaktiviert.

Wurde der Registry-Wert auf EnableActiveProbing = 1 gesetzt, konnten nach einem Neustart manuelle DSN-Serveradressen eingegeben werden und die Internetanzeige funktionierte wieder. Vielleicht hilft es ja jemandem.